百炼 1753:Flip Game

1753:Flip Game


  • 查看
  • 提交
  • 统计
  • 提示
  • 提问
总时间限制: 
1000ms 
内存限制: 
65536kB
描述
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

百炼 1753:Flip Game_第1张图片Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
输入
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
输出
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
样例输入
bwwb
bbwb
bwwb
bwww
样例输出
4
 
   
 
   
 
   
 
   
 
   
   
#include "iostream"
using namespace std;
bool Map[4][4];
int Move[5][2]={0,0,0,1,1,0,0,-1,-1,0};

int count;
void Flip(int x,int y)
{
      int i;
	  for(i=0;i<5;i++)
	  { 
         int dx,dy;
		 dx=x+Move[i][0];
		 dy=y+Move[i][1];
         if(dx>=0 && dx<4 && dy>=0 && dy<4)
		 {
             if(Map[dx][dy]==true)
			 Map[dx][dy]=false;
			 else
			 Map[dx][dy]=true;
		 }
	  }

}
bool Judge()
{
	for(int i=0;i<4;i++)
	{
		for(int j=0;j<4;j++)
		{
			if(Map[i][j]!=Map[0][0])
			return false;
		}
	}
    return true;
}

 
bool flag;
void Dfs(int x,int y,int degree)
{      
 
	  if(flag==true) return;
      if(degree==count)
	  {
		  if(Judge())
		  {
		    flag=true;	 
		  }
		  return ;
	  }
  	  if(x==4) return;

	  int dx,dy;
	  if(y==3)
	  {
		  dx=x+1;
		  dy=0;
	  }
	  else
	  {
		  dx=x;
		  dy=y+1;
	  }
      if(x==-1 && y==-1)
	  {
		  dx=0;dy=0;
	  }
	  
      Flip(dx,dy);
      Dfs(dx,dy,degree+1);    
      Flip(dx,dy);
	  Dfs(dx,dy,degree);
}

int main( )
{   
	//freopen("1.txt","r",stdin);

	int i,j;
	for(i=0;i<4;i++)
    {
		for(j=0;j<4;j++) 
		{ 
			char x;
			cin>>x;
            if(x=='b')
			Map[i][j]=true;
		}
	}
    
	for(count=0;count<17;count++)
	{  
		Dfs(-1,-1,0);
		if(flag)
		break;
	}
    
	if(flag==false)
    cout<<"Impossible"<<endl;
	else
	cout<<count<<endl;


	return 0;
}
 


你可能感兴趣的:(百炼 1753:Flip Game)