Cyclic Nacklace
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5594 Accepted Submission(s): 2530
Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.
As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:
Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
Sample Input
Sample Output
Author
possessor WC
Source
HDU 3rd “Vegetable-Birds Cup” Programming Open Contest
Recommend
lcy | We have carefully selected several similar problems for you: 1358 1686 2222 3068 2896
题意:
求最少添加多少字母使字符串形成循环。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
char B[100005] ;
int Next[100005];
void GetNext(int n)
{
Next[0]=0;
int q=0,i;
for(i=1;i<n;i++)
{
while(q>0&&B[i]!=B[q])
q=Next[q-1];
if(B[i]==B[q])
q++;
Next[i]=q;
}
}
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
scanf("%s",B);
int m=strlen(B);
GetNext(m);
int xunhuan=m-Next[m-1];//未成循环的个数。
if(Next[m-1]==0)//这种情况应全部重新添加一次
printf("%d\n",m);
else//下面是避免aaaa这种情况。
if(m%xunhuan==0)//
printf("0\n");
else
printf("%d\n",xunhuan-Next[m-1]%xunhuan);
}
return 0 ;
}