hdu-1260 Tickets【dp】


H - Tickets
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u
Submit Status

Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input

     
     
     
     
2 2 20 25 40 1 8
 

Sample Output

   
   
   
   
08:00:40 am 08:00:08 am

很简单的一个dp

这里的数据依次表示的意思为:第一个2,代表两组数据,然后下面的2表示两个人,如果单买票的话,其中第一个人会花费20S,另一个人会花费25S,如果两人一起买要花费40S(注意这里的两人一起买必须是相挨着的两个人才可以),题目求最短买票时间

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAX_SIZE 2010
#define find_min(a,b) a>b?b:a
int k;
int cost[MAX_SIZE];
int together[MAX_SIZE];
int dp[MAX_SIZE];
int DP()
{
	int ans=0;
	memset(dp,0x3f,sizeof(dp));
	dp[0]=0;
	dp[1]=cost[1];
	for(int i=2;i<=k;++i)
		dp[i]=find_min(dp[i-1]+cost[i],dp[i-2]+together[i-1]);
	return dp[k];
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&k);
		for(int i=1;i<=k;++i)
			scanf("%d",cost+i);
		for(int i=1;i<=k-1;++i)
			scanf("%d",together+i);
		int res=DP();
		int a=8,b=0,c=res;
		b+=c/60;c%=60;
		a+=b/60;b%=60;
		a%=60;
		printf("%02d:%02d:%02d am\n",a,b,c);
	}
	return 0;
}


你可能感兴趣的:(dp)