POJ 2000 Gold Coins

Gold Coins
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 21046   Accepted: 13195

Description

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer.

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

Input

The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with Day 1.

Sample Input

10
6
7
11
15
16
100
10000
1000
21
22
0

Sample Output

10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98

 

题目大意:

国王给骑士奖励,第一天一枚硬币,接下来的两天,每一天两枚硬币。接下来的三天,每天三枚硬币。接下来的四天,每天四枚硬币。

请编写程序,在已知天数的情况下,求出国王要支付给其实的硬币总数。

解法:

一个循环,i记录天数和ans记录硬币总数。

#include <iostream>
using namespace std;
int main()
{
	int n;
	while(cin>>n&&n)
	{
	int ans=0;
	for(int i=0,j=1;i<=n;j++)
	{
		int k=j;
		while(k--&&++i<=n)
			ans+=j;
	}
	cout<<n<<" "<<ans<<endl;
	}
	return 0;
}



你可能感兴趣的:(POJ 2000 Gold Coins)