Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12086 Accepted Submission(s): 5011
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
Source
Asia 2001, Taejon (South Korea)
Recommend
We have carefully selected several similar problems for you: 1050 2037 1052 1045 1053
类似于会场安排问题,点有5000个, 可以贪心解决,如果点少,其实可以建图,然后dfs染色去做,求出最少用的点数
#include <set>
#include <map>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 5010;
struct node
{
int l, w;
}wood[N];
bool mark[N];
int cmp(node a, node b)
{
if (a.l != b.l)
{
return a.l < b.l;
}
return a.w < b.w;
}
int main()
{
int t, n;
scanf("%d", &t);
while (t--)
{
scanf("%d", &n);
memset (mark, 0, sizeof(mark) );
for (int i = 0; i < n; ++i)
{
scanf("%d%d", &wood[i].l, &wood[i].w);
}
sort(wood, wood + n, cmp);
int ans = 0;
int mark_num = 0;
int p;
while (mark_num < n)
{
for (int i = 0; i < n; ++i)
{
if(mark[i] == 0)
{
p = i;
break;
}
}
ans++;
mark_num++;
mark[p] = 1;
for (int i = 0; i < n; ++i)
{
if (mark[i])
{
continue;
}
if(wood[i].l >= wood[p].l && wood[i].w >= wood[p].w)
{
mark[i] = 1;
mark_num++;
p = i;
}
}
}
printf("%d\n", ans);
}
return 0;
}