hdu 1325 Vs hdu 1272 is it a tree ? 并查集:对是否是树的判断

http://acm.hdu.edu.cn/showproblem.php?pid=1325

Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

hdu 1325 Vs hdu 1272 is it a tree ? 并查集:对是否是树的判断_第1张图片 hdu 1325 Vs hdu 1272 is it a tree ? 并查集:对是否是树的判断_第2张图片 hdu 1325 Vs hdu 1272 is it a tree ? 并查集:对是否是树的判断_第3张图片

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 
 

Sample Input
   
   
   
   
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
   
   
   
   
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
点击打开链接

#include <stdio.h>
#include <iostream>
using namespace std;
struct note
{
    int root,du,num;
};
note a[100010];
void isis()
{
    for(int i=0; i<100010; i++)
    {
        a[i].root=i;
        a[i].du=0;
        a[i].num=0;
    }
}
int find(int x)
{
    if(a[x].root==x)
        return x;
    return a[x].root=find(a[x].root);
}
void un(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y)
       return;
    a[y].root=x;
}
int main()
{
    int m,n,t=1;
    int flag=1;
    isis();
    while(~scanf("%d%d",&n,&m)&&n>=0&&m>=0)
    {
        if(!flag&&n!=0&&m!=0)
            continue;
        if(n==0&&m==0)
        {
            int num1=0;
            for(int i=1; i<100010; i++)
            {
                if(a[i].num&&find(i)==i)
                {
                    num1++;
                }
                if(a[i].du>1)
                {
                    flag=0;
                    break;
                }
            }
            if(num1>1)
            {
                flag=0;
            }
            if(flag)
                printf("Case %d is a tree.\n",t++);
            else
                printf("Case %d is not a tree.\n",t++);
            flag = true;
            isis();
            continue;
        }
        if((m!=n&&find(n)==find(m))||m==n)
            flag=false;
        else
        {
            a[m].num=1;
            a[n].num=1;
            a[m].du++;
            un(n,m);
        }
    }
    return 0;
}


你可能感兴趣的:(hdu 1325 Vs hdu 1272 is it a tree ? 并查集:对是否是树的判断)