FatMouse's Speed
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7290 Accepted Submission(s): 3222
Special Judge
Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.
The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.
Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that
W[m[1]] < W[m[2]] < ... < W[m[n]]
and
S[m[1]] > S[m[2]] > ... > S[m[n]]
In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
Source
Zhejiang University Training Contest 2001
Recommend
Ignatius
按照其中一个排序,再求另一个的最长上升子序列,记住去记录路径
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <iomanip>
using namespace std;
//#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid , rt << 1
#define rson mid + 1 , r , rt << 1|1
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
#define mid ((l + r) >> 1)
#define mk make_pair
const int MAXN = 10000 + 50;
const int maxw = 100 + 20;
const int MAXNNODE = 10000 +10;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
#define eps 1e-8
#define mod 10007
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pii;
const D e = 2.718281828459;
struct mouse
{
int w,s , num;
}a[MAXN];
int cmp (const mouse a , const mouse b)
{
if(a.w != b.w)return a.w > b.w;
return a.s < b.s;
}
int main()
{
//ios::sync_with_stdio(false);
#ifdef Online_Judge
freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);
#endif // Online_Judge
int n = 1;
int maxi , mi ;
int dp[MAXN];
int path[MAXN];
FORR(i , 1 , MAXN)path[i]=i;
while(~scanf("%d%d" , &a[n].w , &a[n].s))
{
a[n].num = n ++;
}
n--;
sort(a + 1, a + n + 1, cmp);
// FORR(i , 1 , n)cout << a[i].w << ' ' << a[i].s << endl;
clr(dp , 0);
int MAX = 0;
FORR(i , 1 , n)
{
int tmp = 0;
FOR(j , 1 , i)
{
if(a[i].s > a[j].s && a[i].w < a[j].w&&tmp < dp[j])
{
tmp = dp[j];
maxi = a[j].num;
}
}
if(tmp)path[a[i].num] = maxi;
dp[i] = tmp + 1;
if(MAX < dp[i])
{
MAX = dp[i];
mi = a[i].num;
}
}
if(MAX == 1)printf("1\n1\n");
else
{
printf("%d\n" , MAX);
while(path[mi] != mi)
{
printf("%d\n" ,mi);
mi = path[mi];
}
printf("%d\n", mi);
}
return 0;
}