POJ 1394 (莫比乌斯反演)

Sky Code
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1964   Accepted: 629

Description

Stancu likes space travels but he is a poor software developer and will never be able to buy his own spacecraft. That is why he is preparing to steal the spacecraft of Petru. There is only one problem – Petru has locked the spacecraft with a sophisticated cryptosystem based on the ID numbers of the stars from the Milky Way Galaxy. For breaking the system Stancu has to check each subset of four stars such that the only common divisor of their numbers is 1. Nasty, isn’t it? Fortunately, Stancu has succeeded to limit the number of the interesting stars to N but, any way, the possible subsets of four stars can be too many. Help him to find their number and to decide if there is a chance to break the system.

Input

In the input file several test cases are given. For each test case on the first line the number N of interesting stars is given (1 ≤ N ≤ 10000). The second line of the test case contains the list of ID numbers of the interesting stars, separated by spaces. Each ID is a positive integer which is no greater than 10000. The input data terminate with the end of file.

Output

For each test case the program should print one line with the number of subsets with the asked property.

Sample Input

4
2 3 4 5 
4
2 4 6 8 
7
2 3 4 5 7 6 8

Sample Output

1 
0 
34

Source

Southeastern European Regional Programming Contest 2008

题意:给定的序列中有多少4元组gcd为1。

设f(x)表示四元组gcd为x的对数,F(x)表示四元组gcd为x的倍数的个数,那么这两个函数满足莫比乌斯反演:


F(x)的值容易求得,对于每一个数a[i]枚举sqrt(a[i])个因子就可以获得他的所有约数然后就可以统计某个数的倍数在数列中出现多少次,假设出现y次,F(x)=C(x,y)。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
#define maxn 11111

long long n;
long long a[maxn];
int prime[maxn], cnt;
bool vis[maxn];
int mu[maxn];

void init () {
    memset (vis, 0, sizeof vis);
    mu[1] = 1;
    cnt = 0;
    for (int i = 2; i <= 10000; i++) {
        if (!vis[i]) {
            prime[cnt++] = i;
            mu[i] = -1;
        }
        for (int j = 0; j < cnt; j++) {
            if (i*prime[j] > 10000)
                break;
            vis[i*prime[j]] = 1;
            if (i%prime[j] == 0) {
                mu[i*prime[j]] = 0;
                break;
            }
            else {
                mu[i*prime[j]] = -mu[i];
            }
        }
    }
}

long long num[maxn];

void add (long long n) {
    for (long long i = 1; i*i <= n; i++) {
        if (n%i == 0) {
            num[n/i]++;
            if (i*i != n)
                num[i]++;
        }
    }
}

long long cal (long long a, long long b) {
    if (b < a)
        return 0;
    return b*(b-1)*(b-2)*(b-3)/24;
}

int main () {
    //freopen ("in.txt", "r", stdin);
    init ();
    while (scanf ("%lld", &n) == 1) {
        memset (num, 0, sizeof num);
        for (int i = 1; i <= n; i++) {
            scanf ("%lld", &a[i]);
            add (a[i]);
        }
        long long ans = 0;
        for (int i = 1; i <= 10000; i++) {
            ans += mu[i]*cal (4, num[i]);
        }
        printf ("%lld\n", ans);
    }
    return 0;
}


你可能感兴趣的:(POJ 1394 (莫比乌斯反演))