HDU 2955 Robberies(经典01背包概率问题)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7179    Accepted Submission(s): 2689


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

HDU 2955 Robberies(经典01背包概率问题)_第1张图片
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
   
   
   
   
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
   
   
   
   
2 4 6
 

Source
IDI Open 2009
 

Recommend
gaojie

 01背包概率问题 : dp[j] = max(dp[j] , dp[j-m[i]] * (1-p[i])); 

/*
特别注意:千万不要认为此题的精度是0.01 这是个深坑
解题思路: 01背包概率问题   dp[j] = max(dp[j] , dp[j-m[i]] * (1-p[i])); 
           
*/
#include<cstdio>
#include<cstring>
#define eps 1e-8
#define N 105

double P[N];
int M[N];
double dp[N*N];
int main ()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		double  p;
		int n;
		scanf("%lf %d", &p, &n);
		p =  1 - p;

		int sum = 0;
		for(int i = 0; i < n; i++)
		{
			scanf("%d %lf", &M[i],&P[i]);
			P[i] = 1 - P[i];
			sum = sum + M[i];           //将所有的银行的金额当做背包的容量
		}

		memset(dp, 0, sizeof(dp));
		dp[0] = 1;                //将dp[0]设置为1
		for(int i = 0; i < n; i++)
			for(int j = sum; j >= M[i]; j--)
				if(dp[j] < dp[j - M[i]] * P[i])
				     dp[j] =  dp[j - M[i]] * P[i];

		 for(int i = sum;i >= 0; i--)
            if(dp[i] - p > eps)          //这里貌似有人dp[i] > p也过了
			{
                printf("%d\n",i);
                break;
            }

	}
	return 0;
}




你可能感兴趣的:(dp)