hoj1740

A New Stone Game
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 3750   Accepted: 1952

Description

Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.

Output

For each test case, if Alice win the game,output 1,otherwise output 0.

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0

Source

LouTiancheng@POJ
题意:先从一堆中选一个扔掉,然后可以从任意一堆中选任意多个移到任意堆中去,最后取完胜
分析:只有一堆,必胜
           两堆的话,若1,2堆的石头相等,则先取的必败,因为后手的可以一直使两堆石头相同
           三堆无论异或如何都必胜
数学归纳:
            奇数堆必胜
           偶数堆,若两两堆的石头相投则必胜(1,2相同,3,4相同,无论先手如何做,后手都可以使两两相同的局势再次出现)
#include <stdio.h>
#include<string.h>
int main(int argc, char *argv[])
{
 int n,m,ans,i;
    int flag[100];
 while(scanf("%d",&n)!=EOF)
 {
  memset(flag,0,sizeof(flag));   //清零别忘记了
  ans=0;
  if (n==0) break;
  for(i=0;i<n;i++)
  {
   scanf("%d",&m);
   if(flag[m])//若有两堆相等,则flag就会在真假中变化,导致ans=0
       ans++;
   else
       ans--; 
       flag[m]=!flag[m];
  }
  if (ans) printf("1\n");
  else printf("0\n");
 }
 return 0;
}
奇数态必胜ans又为真

你可能感兴趣的:(hoj1740)