POJ1068解题报告

Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11181   Accepted: 6583

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
 
题意:一个括号表达式可以按照如下的规则表示,就是每个右括号之前的左括号数。
比如(((()()()))),每个右括号之前的左括号数序列为P=4 5 6 6 6 6,而每个右括号所在的括号内包含的括号数为W=1 1 1 4 5 6.
现在给定P,输出W。
我的思路:先根据P还原整个括号表达式,存在数组中,然后递归解出W..
#include<iostream>
using namespace std;
char y[10000];	int p[50],w[50],n,l,j;
int f()
{
	int s=1;
	while(1)
		if(y[j]=='(')
		{
			j++;
			s+=f();
		}
		else
		{
			w[l++]=s;
			j++;
			return s;
		}
}
int main()
{
	int t,i,k;
	cin>>t;
	while(t--)
	{
		cin>>n;
		for(i=0,l=0,k=0;i<n;i++)
		{
			cin>>p[i];
			for(j=0;j<p[i]-k;j++)
				y[l++]='(';
			y[l++]=')';
			k=p[i];
		}
		l=j=0;
		f();
		for(i=0;i<n;i++)
			cout<<w[i]<<' ';
		cout<<endl;
	}
	return 0;
} 



你可能感兴趣的:(String,Integer,ini,input,each,output)