Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35547 Accepted Submission(s): 14631
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
未进行优化的代码:
#include <iostream>
#include <cstring>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int max(int a,int b)
{
return (a>b)?a:b;
}
int val[1005],vol[1005];
int v[1005][1005];
int main(int argc, char *argv[]) {
int t;
int n,vv;
cin>>t;
while(t--)
{
cin>>n>>vv;
for(int i=1;i<=n;i++)
cin>>val[i];
for(int i=1;i<=n;i++)
cin>>vol[i];
for(int i=0;i<=n;i++)
v[i][0]=0;
for(int j=0;j<=vv;j++)
v[0][j]=0;
memset(v,0,sizeof(v));
int i,j;
for(i=1;i<=n;i++)
{
for(j=0;j<=vv;j++)
{
if(vol[i]<=j)
{
v[i][j]=max(v[i-1][j],v[i-1][j-vol[i]]+val[i]);
}
else
v[i][j]=v[i-1][j];
}
}
cout<<v[n][vv]<<endl;
}
return 0;
}
优化后:
#include <iostream>
#include <cstring>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int max(int a,int b)
{
return (a>b)?a:b;
}
int val[1005],vol[1005];
int v[1005];
int main(int argc, char *argv[]) {
int t;
int n,vv;
cin>>t;
while(t--)
{
cin>>n>>vv;
for(int i=1;i<=n;i++)
cin>>val[i];
for(int i=1;i<=n;i++)
cin>>vol[i];
for(int i=0;i<=vv;i++)
v[i]=0;
memset(v,0,sizeof(v));
int i,j;
for(i=1;i<=n;i++)
{
for(j=vv;j>=0;j--)
{
if(vol[i]<=j)
{
v[j]=max(v[j],v[j-vol[i]]+val[i]);
}
}
}
cout<<v[vv]<<endl;
}
return 0;
}