Legal or Not(HDU_3342)

Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output “YES”, otherwise “NO”.

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

这题并没有什么难点,普通的有向图求有无回路,在清零上WA了两发...太不应该了...

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>

using namespace std;

vector<int>g[110];
int degree[110];

bool toposort(int n)
{
    memset(degree,0,sizeof(degree));
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<g[i].size();j++)
        {
            degree[g[i][j]]++;
        }
    }
    queue<int>q;
    for(int i=0;i<n;i++)
    {
        if(!degree[i])
            q.push(i);
    }
    int tot=0;
    while(q.size())
    {
        int qq=q.front();
        q.pop();
        tot++;
        for(int i=0;i<g[qq].size();i++)
        {
            degree[g[qq][i]]--;
            if(degree[g[qq][i]]==0)
                q.push(g[qq][i]);
        }
    }
    if(tot==n) return 1;
    return 0;
}

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&n)
    {
        int a,b;
        memset(g,0,sizeof(g));//清零清零清零!!!!!
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            g[a].push_back(b);
        }
        if(toposort(n))
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

你可能感兴趣的:(Legal or Not(HDU_3342))