递推—杭电2041 超级楼梯

http://acm.hdu.edu.cn/showproblem.php?pid=2041

超级楼梯

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27838    Accepted Submission(s): 14362


Problem Description
有一楼梯共M级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第M级,共有多少种走法?
 


 

Input
输入数据首先包含一个整数N,表示测试实例的个数,然后是N行数据,每行包含一个整数M(1<=M<=40),表示楼梯的级数。
 


 

Output
对于每个测试实例,请输出不同走法的数量
 


 

Sample Input
   
   
   
   
2 2 3
 


 

Sample Output
   
   
   
   
1 2

 

#include <iostream>
using namespace std;
int main()
{
    int f(int );
    int n,j;
    cin>>n;
    for(j=1;j<=n;j++)
    {
        int m;
        cin>>m;
        int i;
        int f1,f2,f3;
        f1=1;f2=2;
        for(i=3;i<m;i++)
        {
            f3=f1+f2;
            f1=f2;
            f2=f3;
        }
        if(m==2)
            cout<<"1"<<endl;
        else if(m==3)
            cout<<"2"<<endl;
        else 
            cout<<f3<<endl;
    }
    return 0;
}


你可能感兴趣的:(递推—杭电2041 超级楼梯)