HDU——1711 Number Sequence

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
    
    
    
    
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
    
    
    
    
6 -1
 

Source
HDU 2007-Spring Programming Contest


在一个串里寻找另一个串第一次出现的位置的下标

kmp的运用。

#include<stdio.h>
#include<string.h>

const int maxn=1000010;

int next[maxn];

int str[maxn],per[maxn];

int len1,len2;

void get_next()
{
next[0]=-1;
int j=0,k=-1;
while(j<len2)
{
if(k == -1 || str[k] == str[j])
{
j++;
k++;
if(str[j] != str[k])
next[j]=k;
else
next[j]=next[k];
}
else
k=next[k];
}
}


int KMP()
{
int index=0;
int i=0,j=0;
get_next();
while(i<len1 && j<len2)
{
if(j==-1 || str[j] == per[i])
{
i++;
j++;
}
else
j=next[j];
}
if(j==len2)//串匹配到底,返回位置
return i-len2+1;
else //匹配失败,未找到
return -1;
}
int main()
{
int t;
while(~scanf("%d",&t))
{
while(t--)
{
scanf("%d%d",&len1,&len2);
for(int i=0;i<len1;i++)
scanf("%d",&per[i]);
for(int i=0;i<len2;i++)
scanf("%d",&str[i]);
printf("%d\n",KMP());
}
}
return 0;
}


你可能感兴趣的:(HDU——1711 Number Sequence)