GCD and LCM
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 74 Accepted Submission(s): 42
Problem Description
Given two positive integers G and L, could you tell me how many solutions of (x, y, z) there are, satisfying that gcd(x, y, z) = G and lcm(x, y, z) = L?
Note, gcd(x, y, z) means the greatest common divisor of x, y and z, while lcm(x, y, z) means the least common multiple of x, y and z.
Note 2, (1, 2, 3) and (1, 3, 2) are two different solutions.
Input
First line comes an integer T (T <= 12), telling the number of test cases.
The next T lines, each contains two positive 32-bit signed integers, G and L.
It’s guaranteed that each answer will fit in a 32-bit signed integer.
Output
For each test case, print one line with the number of solutions satisfying the conditions above.
Sample Input
Sample Output
Source
2013 ACM-ICPC吉林通化全国邀请赛——题目重现
思路来源于:大牛博客 点此进入 (代码写的也比我简洁易懂)
思路:
将满足条件的一组x,z,y都除以G,得到x‘,y',z',满足条件gcd(x',y',x') = 1,同时lcm(x',y',x') = G/L.
特判,当G%L != 0 时,无解。
然后素数分解G/L,假设G/L = p1^t1 * p2^t2 *````* pn^tn。
满足上面条件的x,y,z一定为这样的形式。
x' = p1^i1 * p2^i2 *```* pn^in.
y' = p1^j1 * p2^j2 * ```*pn^jn.
z' = p1^k1 * p2^k2 * ```*pn^kn.
为了满足上面的条件,对于p1,一定有max(i1,j1,k1) = t1.min(i1,j1,k1) =0;则当选定第一个数为0,第二个数为t1时,第三个数可以为0-t1,又由于有顺序的,只有(0,t1,t1) 和(0,t1,0)这两种情形根据顺序只能产生三种结果,其他的由于三个数都不一样,一定能产生6种,所以最后产生了6*(t1-1)+3*2 = 6*t1种,根据乘法原理以及关于素数分解的唯一性,反过来,素数组合必然也是唯一的数,一共有6*t1 * 6*t2 *`````*6*tn种选法。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define maxn 100005
using namespace std;
int n,m,cxx;
long long ans;
int cnt[maxn];
void solve()
{
int i,j,t,m=n;
memset(cnt,0,sizeof(cnt));
t=sqrt(n*1.0+0.5);
for(i=2;i<=t;i++)
{
if(n%i==0)
{
while(n%i==0)
{
n=n/i;
cnt[i]++;
}
}
}
if(n!=1) ans=6;
else ans=1;
for(i=1;i<=t;i++)
{
if(cnt[i]) ans=ans*6*cnt[i];
}
}
int main()
{
int i,j,t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
if(m%n!=0) printf("0\n");
else
{
n=m/n;
solve();
printf("%I64d\n",ans);
}
}
return 0;
}