【哈工大oj】1551 - 基础数据结构——字符串2 病毒II(水)

基础数据结构——字符串2 病毒II
Time Limit: 1000 MS Memory Limit: 10240 K
Total Submit: 827(308 users) Total Accepted: 455(298 users) Rating:  Special Judge: No
Description

自从计算机病毒的概念被提出之后,病毒的种类可以说是层出不穷。现在,单纯的病毒是逃不过杀毒软件的。因此现在的病毒往往隐藏一些字符之中来达到蒙混过关的目的。已知连续的字符串"bkpstor"是一段病毒编码,请分析给出的一段字符串中是否包含病毒编码。

Input

本题有多组测试数据,对于每组数据输入一个字符串Str(长度不超过100),处理到文件结束。

Output

如果字符串中包含病毒编码,输出Warning并换行,否则输出Safe并换行。

Sample Input

123455676sa

Sample Output

Safe

Author
杨和禹@HRBUST


简单水题。

代码如下:

#include <stdio.h>
#include <string.h>
char a[111];
int main()
{
	int l;
	int ans;
	while (scanf ("%s",a)!=EOF)
	{
		ans=0;
		l=strlen(a);
		for (int i=0;i<=l-7;i++)
		{
			if (a[i]=='b');
				if (a[i+1]=='k')
					if (a[i+2]=='p')
						if (a[i+3]=='s')
							if (a[i+4]=='t')
								if (a[i+5]=='o')
									if (a[i+6]=='r')
									{
										ans=1;
										break;
									}
		}
		if (ans)
			printf ("Warning\n");
		else
			printf ("Safe\n");
		memset (a,'0',sizeof (a));
	}
	return 0;
}


你可能感兴趣的:(【哈工大oj】1551 - 基础数据结构——字符串2 病毒II(水))