POJ 2955 Brackets

K - Brackets
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 2955
Appoint description:

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im n, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6


这几天都在做区间dp的题

做到这题的时候思路很清晰很快就ac了

ACcode:

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define maxn 110
using namespace std;
int dp[maxn][maxn];
char str[maxn];
int main(){
    while(scanf("%s",str+1)&&strcmp(str+1,"end")){
        memset(dp,0,sizeof(dp));
        int n=strlen(str+1);
        for(int l=2;l<=n;++l)
            for(int i=1;i+l-1<=n;++i){
                int j=i+l-1;
                for(int k=i;k<=j;++k)dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
                if(str[i]=='('&&str[j]==')'||str[i]=='['&&str[j]==']')dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
            }
       /* for(int i=1;i<=n;++i){
            for(int j=1;j<=n;++j){
                cout<<dp[i][j]<<' ';
            }
            cout<<'\12';
        }*/
        int ans=0;
        for(int i=1;i<=n;++i){
            ans=max(ans,dp[1][i]+dp[i+1][n]);
          //  cout<<dp[1][i]<<"      "<<dp[i+1][n]<<'\12';
        }
        printf("%d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(C++,ACM,poj)