http://poj.org/problem?id=2431
Description
A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.
To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).
The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).
Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input
* Line 1: A single integer, N
* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.
* Line N+2: Two space-separated integers, L and P
Output
* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10
Sample Output
2
Hint
INPUT DETAILS:
The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.
OUTPUT DETAILS:
Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
STL中的优先队列的含义就是在队列出队时首先出队的是数值最大的那个元素。优先队列的头文件在<queue>中,其基本操作有:
1,定义:priority_queue<类型> 名称,eg:priority_queue<int >que; -> 定义了一个名为que的元素类型为基本整型的优先队列
2,插入元素:que.push(要插入的元素);
3,出队:que.top();
4,删除队头元素 que.pop();
5,que.empty();队列为空返回真
6,返回队列中元素的个数 que.size();
另外:优先队列的优先级默认的是大的数优先,有时候需要自定义优先级。
struct cmp//小的数优先
{
bool operator ()(int x,int y)
{
return x>y;
}
};
priority_queue<int,vector<int>,cmp>que;
struct node//结构体的优先顺序自定义
{
int x, y;
friend bool operator < (node a, node b)
{
return a.x > b.x; //结构体中,x小的优先级高
}
};
priority_queue<node>q;
代码:
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
struct note
{
int a,b;
}aa[10005];
bool cmp(note a,note b)
{
return a.a<b.a;
}
int n,l,p;
void solve()
{
aa[n].a=l;
aa[n++].b=0;
priority_queue<int> que;
int pos=0,tank=p,ans=0;
for(int i=0;i<n;i++)
{
int d=aa[i].a-pos;
while(tank-d<0)
{
if(que.empty())
{
puts("-1");
return;
}
tank+=que.top();
que.pop();
ans++;
}
tank-=d;
pos=aa[i].a;
que.push(aa[i].b);
}
printf("%d\n",ans);
}
int main()
{
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
scanf("%d%d",&aa[i].a,&aa[i].b);
scanf("%d%d",&l,&p);
for(int i=0;i<n;i++)
aa[i].a=l-aa[i].a;
sort(aa,aa+n,cmp);
solve();
}
return 0;
}