POJ3661——Running

Running
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5232   Accepted: 1938

Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

Source

USACO 2008 January Silver

区间dp,我是这么做的:设dp[i]表示从i分钟到n分钟,最多可以达到的距离
关于状态方程我调了好久才对
关键是要在区间[i,n]中找到一个时间点k,k之前一直跑,中间一段时间是休息的,然后加上一个子区间的dp值


#include <map>  
#include <set>  
#include <list>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  
  
using namespace std;

const int N = 10010;
int dp[N];
int d[N];
int sum[N];

int main()
{
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		memset (dp, 0, sizeof(dp));
		sum[0] = 0;
		for (int i = 1; i <= n; ++i)
		{
			scanf("%d", &d[i]);
			sum[i] = sum[i - 1] + d[i];
		}
		for (int i = n - 1; i >= 1; --i)
		{
			for (int k = 0; k <= m; ++k)
			{
				if (k == 0)
				{
					dp[i] = max(dp[i], dp[i + 1]);
					continue;
				}
				if (i + 2 * k - 1 <= n)
				{
					dp[i] = max(dp[i], sum[k + i - 1] - sum[i - 1] + dp[i + 2 * k]);
				}
			}
		//	printf("dp[%d] = %d\n", i, dp[i]);
		}
		int ans = 0;
		for (int i = 1; i <= n; ++i)
		{
			ans = max(ans, dp[i]);
		}
		printf("%d\n", ans);
	}
	return 0;
}


你可能感兴趣的:(dp)