Robberies hdu 01 背包

                              Robberies

               Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
              Total Submission(s): 8082 Accepted Submission(s): 3058


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

Robberies hdu 01 背包_第1张图片
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input
   
   
   
   
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05

Sample Output
   
   
   
   
2 4 6

Source
IDI Open 2009 

和上一题一样,垂涎已久的题了~

以钱作为背包,进行求解,收获最大的是对背包的判断  还有define max的应用 
dp[j]=max(dp[j],dp[j-money[i]]*probability[i]);

先想好阶段 :1~i家银行嘛

在弄好状态: 能跑的了的最大的概率

决策:抢或不抢

那还差一个体积(背包容量)了,这里就用的总钱数


code:

#include<iostream>
#include<algorithm>
using namespace std;
double dp[10005];
int money[10005];
 double probability[10005];
    
int main()
{
	int cas;

	double p;
	int n;
	int total;
	
	cin>>cas;
	while(cas--)
	{
		cin>>p>>n;
		p=1-p;
		total=0;
		memset(money,0,sizeof(money));
		memset(probability,0,sizeof(probability));
		for(int i=1;i<=n;i++)
		{
			cin>>money[i]>>probability[i];
			total+=money[i];
			probability[i]=1-probability[i];			
		}
		dp[0]=1;
		for(int i=1;i<=total;i++)
		{
			dp[i]=0;
		}
		for(int i=1;i<=n;i++)
		 for(int j=total;j>=money[i];j--)
		 {
 			dp[j]=max(dp[j],dp[j-money[i]]*probability[i]);
 		//	cout<<dp[j]<<endl;
 		}     
		 //抢得j大洋之后,最大的逃跑概率 
 		int ans=0;
 		for(int i=total;i>=0;i--)
 		{
		 	if(dp[i]>p)//dp[i]是跑不了的概率,想了良久,i:=total-->0 因为total越大 dp[i]越小~ 
		 	{
		 		//cout<<dp[i]<<"  >   "<<p<<endl;
			    ans=i;
			     break;			 
			 } 
		 	
		 }
		 cout<<ans<<endl;		
	}
	return 0;
}




你可能感兴趣的:(Robberies hdu 01 背包)