HDU 5214 Movie

Problem Description
Cloud and Miceren like watching movies. 

Today, they want to choose some wonderful scenes from a movie. A movie has  N  scenes can be chosen, and each scene is associate with an interval [ L R ].  L  is the beginning time of the scene and  R  is the ending time. However, they can't choose two scenes which have overlapping intervals. (For example, scene with [1, 2] and scene with [2, 3], scene with [2, 5] and scene with[3, 4]). 

Now, can you tell them if they can choose such three scenes that any pair of them do not overlap? 

Since there are so many scenes that you can't get them in time, we will give you seven parameters  N, L1, R1, a, b, c, d , and you can generate  L1  ~  LN R1  ~  RN  by these parameters.
 

Input
The first line contains a single integer  T , indicating the number of test cases.

Each test case contains seven integers  N, L1, R1, a, b, c, d , meaning that there are  N  scenes. The i-th scene's interval is [ Li, Ri ].  L1  and  R1  have been stated in input, and  Li = (Li1  a + b) mod 4294967296, Ri = (Ri1  c + d) mod 4294967296

After all the intervals are generated, swap the i-th interval's  Li  and  Ri  if  Li > Ri .


T  is about 100.

1  N  10000000 .

1  L1,R1  2000000000 .

1  a,b,c,d  1000000000 .

The ratio of test cases with  N > 100  is less than 5%.
 

Output
For each test, print one line.

If they can choose such three scenes, output "YES", otherwise output "NO".
 

Sample Input
   
   
   
   
2 3 1 4 1 1 1 1 3 1 4 4 1 4 1
 

Sample Output
   
   
   
   
NO YES
贪心判断就好了。
#include<cstdio>
#include<string>
#include<queue>
#include<cstring>
#include<iostream>
#include<map>
#include<stack>
#include<malloc.h>
#include<algorithm>
using namespace std;
const int maxn = 10000005;
const long long base = 4294967296;
int n, F, T;
long long l, r, a, b, c, d;

void check()
{
    long long y = -1, y0 = -1;
    for (long long i = 1, L = l, R = r, u, v; i <= n; i++)
    {
        u = L; v = R;
        if (u > v) swap(u, v);

        if (v < y || y<0) y = v;

        if (u > y) if (v< y0 || y0 < 0) y0 = v;

        if (u > y0 && y0>0) { F = 1; return; }

        L = (L * a + b) % base;
        R = (R * c + d) % base;
    }
    for (long long i = 1, L = l, R = r, u, v; i <= n; i++)
    {
        u = L; v = R;
        if (u > v) swap(u, v);

        if (v < y || y<0) y = v;

        if (u > y) if (v< y0 || y0 < 0) y0 = v;

        if (u > y0 && y0>0) { F = 1; return; }

        L = (L * a + b) % base;
        R = (R * c + d) % base;
    }
    F = 0;
}

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        F = 0;
        cin >> l >> r >> a >> b >> c >> d;
        check();
        if (F) printf("YES\n"); else printf("NO\n");
    }
    return 0;
}


你可能感兴趣的:(HDU)