POJ2192:Zipper(DP)

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no
题意:问前两个串的字符按顺序取出能否组成第三个串
思路:比较简单的DP,dp[i][j]表示从s1中取到了第i个字符,s2中取到了第j个字符所组成的s3的状况,1则能组成,0则不能组成
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

char s1[500],s2[500],s3[500];
int dp[500][500];

int main()
{
    int t,i,j,k,len1,len2,len3,cas = 1 ;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%s%s",s1+1,s2+1,s3+1);
        len1 = strlen(s1+1);
        len2 = strlen(s2+1);
        len3 = strlen(s3+1);
        memset(dp,0,sizeof(dp));
        for(i = 1; i<=len1; i++)
        {
            if(s1[i] == s3[i])
                dp[i][0] = 1;
            else break;
        }
        for(i = 1; i<=len2; i++)
        {
            if(s2[i] == s3[i])
                dp[0][i] = 1;
            else break;
        }
        for(i = 1; i<=len1; i++)
        {
            for(j = 1; j<=len2; j++)
            {
                if(s3[i+j] == s1[i] && dp[i-1][j])
                    dp[i][j] = 1;
                if(s3[i+j] == s2[j] && dp[i][j-1])
                    dp[i][j] = 1;
            }
        }
        printf("Data set %d: ",cas++);
        if(dp[len1][len2])
            printf("yes\n");
        else
            printf("no\n");
    }

    return 0;
}

 
 

你可能感兴趣的:(dp,poj)