UVA - 568 - Just the Facts (简单数论!)

UVA - 568
Just the Facts
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description


  Just the Facts 

The expression  N!, read as ``  N factorial," denotes the product of the first  N positive integers, where  N is nonnegative. So, for example,

N N!
0 1
1 1
2 2
3 6
4 24
5 120
10 3628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ( ). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer  N, you should read the value and compute the last nonzero digit of  N!.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the value  N, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain ``  -> " (space hyphen greater space). Column 10 must contain the single last non-zero digit of  N!.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8


Miguel A. Revilla
1998-03-10

Source


Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Mathematics :: Number Theory ::  Factorial
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Mathematics :: Number Theory :: Factorial
Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 5. Mathematics ::  Factorial
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 1. Elementary Problem Solving ::  Maths - Number Theory


AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <string>
#include <cstdlib>
#include <queue>
#include <stack>
#include <set> 
#include <algorithm>
#define LL long long
using namespace std;

int main()
{
	int n;
	while(scanf("%d", &n)!=EOF)
	{
		int ans=1;
		for(int i=1; i<=n; i++)
		{
			ans*=i;
			while(ans%10==0)
			{
				ans/=10;
			}
			ans%=100000;
		}
		printf("%5d -> %d\n", n, ans%10);
	}
	return 0;
}




你可能感兴趣的:(数论,ACM,uva)