poj 2506 Tiling

                                                                                                                                  
前半生写过的最复杂的JAVA 代码,感觉自己萌萌哒(java 大数就是 daio)

                                                                                                                               
                                                               Tiling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8106   Accepted: 3925

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

4


import java.util.*;
import java.math.*;

public class Main
{
	static BigInteger[] ans;
	public static void main(String[] args)
	{
		Scanner in = new Scanner(System.in);
		int n;
		ans = new BigInteger[255];
		ans[0] = BigInteger.valueOf(1);
		ans[1] = BigInteger.valueOf(1);
		ans[2] = BigInteger.valueOf(3);
		for(int i=3;i<=250;i++)
		{
			ans[i] = ans[i-1].add(ans[i-2].multiply(BigInteger.valueOf(2)) );
		}
		while(in.hasNext())
		{
			n = in.nextInt();
			System.out.println(ans[n]);
		}
	}

}


你可能感兴趣的:(poj)