HDU 2087 剪花布条

Problem Description
一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢?
 

Input
输入中含有一些数据,分别是成对出现的花布条和小饰条,其布条都是用可见ASCII字符表示的,可见的ASCII字符有多少个,布条的花纹也有多少种花样。花纹条和小饰条不会超过1000个字符长。如果遇见#字符,则不再进行工作。
 

Output
输出能从花纹布中剪出的最多小饰条个数,如果一块都没有,那就老老实实输出0,每个结果之间应换行。
 

Sample Input
   
   
   
   
abcde a3 aaaaaa aa #
 

Sample Output
   
   
   
   
0 3
 
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char str[1000],str1[1000];
int next[1000];
/*void get_next()
{
    int len=strlen(str);
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||str[i]==str1[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}*/
void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    while(str[i])
    {
        if(j==-1||str1[i]==str1[j])
        {
            i--;j=-1;;next[i]=j;
        }
        else
            j=next[j];
    }
}
int main()
{
    int i,j,cnt;
    while(~scanf("%s",str)&&strcmp(str,"#"))
    {
        scanf("%s",str1);
        int len=strlen(str),len1=strlen(str1);
        get_next();
        cnt=0;
        i=0;j=0;
        while(i<len)
        {
            if(j==len1)
                cnt++;
            if(j==-1||str[i]==str1[j])
            {
                i++;
                j++;
            }
            else
                j=next[j];
        }
        if(len==i&&len1==j)
            cnt++;
        cout<<cnt<<endl;
    }
    return 0;
}


你可能感兴趣的:(HDU 2087 剪花布条)