poj 2229 Sumsets DP

Sumsets
Time Limit: 2000MS   Memory Limit: 200000K
Total Submissions: 11618   Accepted: 4677

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

USACO 2005 January Silver

Source Code

Problem: 2229		
Memory: 4076K		Time: 79MS
Language: C		Result: Accepted
Source Code
#include <stdio.h>
#define N 1000005
#define M 1000000000
int dp[N];

int main()
{
	int n, i;
	scanf("%d", &n);
	dp[0] = dp[1] = 1;
	for(i=2; i <= n; i++)
		if(i & 0x01)
			dp[i] = dp[i-1];
		else 
			dp[i]=(dp[i-2] + dp[i>>1])%M;
	printf("%d\n", dp[n]);
	return 0;
}


你可能感兴趣的:(poj 2229 Sumsets DP)