HDU 1071 The area(计算几何)

Description
二维平面有一条直线与一条开口向下的抛物线相交,现在给出抛物线顶点以及两个交点,求出直线与抛物线围成的面积,保证数据合法
Input
第一行为用例组数T,每组用例占三行分别输入抛物线顶点P1,左交点P2以及右交点P3的横纵坐标
Output
输出直线与抛物线围成的面积
Sample Input
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222
Sample Output
33.33
40.69
Solution
设抛物线方程为y=y1-a*(x-x1)^2,带入点(x3,y3)得a=,由两交点得到直线方程,所以直线与抛物线围成的面积这里写图片描述
Code

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    double x1,x2,x3,y1,y2,y3;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
        double ans=0;
        ans=(y1-y3)*(x3-x2)-(y1-y3)*(pow(x3-x1,3)-pow(x2-x1,3))/(3.0*pow(x3-x1,2))+(y3-y2)*(x3-x2)/2.0;
        printf("%.2lf\n",ans);
    }
    return 0;
}

你可能感兴趣的:(HDU 1071 The area(计算几何))