joj1048

 1048: Wooden Sticks

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
3s 8192K 884 291 Standard

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2). 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output

2
1
3

Submit / Problem List / Status / Discuss




#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
class NODE
{
public:
    int x;int y;
};


int cmp( const NODE &a, const NODE &b ){
    if( a.x < b.x )
       return 1;
    else
       if( a.x == b.x ){
          if( a.y < b.y )
             return 1;
          else
             return 0;
        }
       else
          return 0;
}


int main()
{
    freopen("in.txt","r",stdin);
    NODE node[5005];
    int visited[5005];
    int t,n;
    scanf("%d",&t);
    for(;t>0;t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&node[i].x,&node[i].y);
            visited[i]=0;
        }
        int m=0;
        sort(node,node+n,cmp);
        /*for(int i=0;i<n;i++)
        {
            printf("%d  %d\n",node[i].x,node[i].y);
        }
        printf("\n\n\n\n\n");*/
        for(int i=0;i<n;i++)
        {
            if(!visited[i])
            {
                m++;
                visited[i]=1;
                int y=node[i].y;
                for(int j=i+1;j<n;j++)
                {
                    if(node[j].y>=y&&!visited[j])
                    {
                        visited[j]=1;
                        y=node[j].y;
                    }
                }
            }
        }
        printf("%d\n",m);
    }
    return 0;
}


这个题的大致思路是先按x排序 再按y排序,找到当后一个大于前一个时不增加时间
,这个题需要注意的事题目的意思是相邻的棒,前面小于后面


你可能感兴趣的:(joj1048)