Basically Speaking
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2909 Accepted Submission(s): 1129
Problem Description
The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.
Its buttons will include the capital letters A through F in addition to the digits 0 through 9.
It will support bases 2 through 16.
Input
The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.
Output
The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right justified in the display.
Sample Input
1111000 2 10 1111000 2 16 2102101 3 10 2102101 3 15 12312 4 2 1A 15 2 1234567 10 16 ABCD 16 15
Sample Output
120 78 1765 7CA ERROR 11001 12D687 D071
AC代码:模拟一下进制的手动转换
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
int main()
{
char c[20];
long int i,j,n,k,a,b,y;
while(scanf("%s%ld%ld",c,&a,&b)!=EOF)
{
char s[20];
k=0;
n=strlen(c);
for(i=0;i<=n;++i) //先转换成十进制
{
if(c[i]>='0'&&c[i]<='9')
y=c[i]-48; //相当于 y=c[i]-'0'
else
switch(c[i])
{
case 'A':y=10;break;
case 'B':y=11;break;
case 'C':y=12;break;
case 'D':y=13;break;
case 'E':y=14;break;
case 'F':y=15;break;
}
k+=(y*(LL)pow(a,n-i-1));
}
if(k==0) {printf(" 0\n");continue;}
i=0;
while(k) //再转换成 b进制
{
y=k%b;
if(y>=0&&y<=9)
s[i]=y+48; //相当于 y=c[i]+'0'
else
switch(y)
{
case 10:s[i]='A';break;
case 11:s[i]='B';break;
case 12:s[i]='C';break;
case 13:s[i]='D';break;
case 14:s[i]='E';break;
case 15:s[i]='F';break;
}
k=k/b;
i++;
}
if(i>7)
printf(" ERROR");
else
{
for(j=0;j<7-i;j++)
printf(" ");
i=i-1;
for(;i>=0;i--)
printf("%c",s[i]);
}
printf("\n");
}
return 0;
}