Line belt
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2517 Accepted Submission(s): 961
Problem Description
In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww's speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.
How long must he take to travel from A to D?
Input
The first line is the case number T.
For each case, there are three lines.
The first line, four integers, the coordinates of A and B: Ax Ay Bx By.
The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.
The third line, three integers, P Q R.
0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000
1<=P,Q,R<=10
Output
The minimum time to travel from A to D, round to two decimals.
Sample Input
1
0 0 0 100
100 0 100 100
2 2 1
Sample Output
题目大意:
给出两条线段AB和CD,在AB上运动有一个速度,在CD上运动有一个速度,两条线段之外有一个速度。现在从A点出发,到达D点。求所需最短时间。
解题思路:
三分法,找出AB上运动到D点的最短时间的点,再找出在CD上的点。那么路线A到D之间经过这两个点的时间就是最短的。
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
#ifdef __int64
typedef __int64 LL;
#else
typedef long long LL;
#endif
#define eps 1e-8//注意精度问题
struct point
{
double x,y;
};
double p,q,r;
double dis(point a,point b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double fund(point a,point c,point d)
{
point mid;
point midmid;
point left=c;
point right=d;
double mid_value,midmid_value;
int flag=0;
while(dis(left,right)>=eps)
{
mid.x=(left.x+right.x)/2.0;
mid.y=(left.y+right.y)/2.0;
midmid.x=(mid.x+right.x)/2.0;
midmid.y=(mid.y+right.y)/2.0;
mid_value=dis(a,mid)/r+dis(mid,d)/q;
midmid_value=dis(a,midmid)/r+dis(midmid,d)/q;
if(mid_value<=midmid_value)
right=midmid;
else left=mid;
flag=1;
}
if(flag)
return mid_value;
else
return dis(a,d)/r;
}
double ans(point a,point b,point c,point d)
{
point mid,midmid;
point left=a;
point right=b;
double mid_value,midmid_value;
int flag=0;
while(dis(left,right)>=eps)
{
mid.x=(left.x+right.x)/2.0;
mid.y=(left.y+right.y)/2.0;
midmid.x=(mid.x+right.x)/2.0;
midmid.y=(mid.y+right.y)/2.0;
mid_value=dis(mid,a)/p+fund(mid,c,d);
midmid_value=dis(midmid,a)/p+fund(midmid,c,d);
if(mid_value<=midmid_value)
right=midmid;
else left=mid;
flag=1;
}
if(flag)
return mid_value;
else
return fund(a,c,d);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
point a,b,c,d;
scanf("%lf%lf%lf%lf",&a.x,&a.y,&b.x,&b.y);
scanf("%lf%lf%lf%lf",&c.x,&c.y,&d.x,&d.y);
scanf("%lf%lf%lf",&p,&q,&r);
printf("%.2lf\n",ans(a,b,c,d));
}
return 0;
}