HDU 3732 Ahui Writes Word

Ahui Writes Word

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 701    Accepted Submission(s): 283


Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.
 

Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)
 

Output
Output the maximum value in a single line for each test case.
 

Sample Input
   
   
   
   
5 20 go 5 8 think 3 7 big 7 4 read 2 6 write 3 5
 

Sample Output
   
   
   
   
15
Hint
Input data is huge,please use “scanf(“%s”,s)”
 

Author
Ahui
 

Source
ACMDIY第二届群赛
 

Recommend
notonlysuccess

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int art[11][11];
int f[10100];
int que[10100], head, tail;

void add(int c, int v, int p, int n){
	while(head < tail && f[p + que[tail - 1] * c] - que[tail - 1] * v <= f[p + n * c] - n * v) tail--;
	que[tail++] = n;
}

int main(){
	int i, j, k, p, v, w;
	int N, V;
	char s[15];
	while(scanf("%d%d", &N, &V) != EOF){
		memset(art, 0, sizeof(art));
		for (k = 0; k < N; k++){
			scanf("%s %d %d", s, &i, &j);
			art[i][j]++;
		}
		memset(f, 0, sizeof(f));
		for (v = 1; v <= 10; v++){
			if (art[v][0] > 0){
				for (j = V; j >= 0; j--)
					f[V] += v * (art[v][0]);
			}
			for (w = 1; w <= 10; w++){
				if (V < w || art[v][w] <= 0) continue;
				for (p = 0; p < w; p++){
					head = tail = 0;
					add(w, v, p, V / w);
					for (j = V / w; j >= 0; j--){
						while(head < tail && que[head] > j) head++;
						while(head < tail && que[tail - 1] > 0 && j - que[tail - 1] < art[v][w]){
							add(w, v, p, que[tail - 1] - 1);
						}
						if (head < tail)
							f[p + j * w] = f[p + que[head] * w] + (j - que[head]) * v;
					}
				}
			}
		}
		printf("%d\n", f[V]);
	}
	return 0;
}
/*
f[t+n*c] = max(f[t+(n-1)*c]+v, f[t+(n-2)*c]+2*v,...) 
= max(f[t+(n-1)*c]-(n-1)*v, f[t+(n-2)*c)-(n-2)*v...) + n*v
f[t+(n-1)*c] = max(f[t+(n-2)*c]+v, f[t+(n-3)*c]+2*v...)
单调队列优化
p = V % c;
q = V / c;
f[p+q*c] = max(f[p+q*c]-q*v, f[p+(q-1)*c]-(q-1)*v,...)+q*v
f[p+(q-1)*c] = max(f[p+(q-1)*c]-(q-1)*v, f[p+(q-2)*c]-(q-2)*v...)+(q-1)*v
单调队列维护f[p+k*c]-k*v
对于每个f[p+k*c],入队k',满足k-k'<=n;出队,大于k的
*/


你可能感兴趣的:(c,Integer,less,input,each,output)