hdoj-1097-A hard puzzle

Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
   
   
   
   
7 66 8 800
 

Sample Output
   
   
   
   
9 6

找规律就好了,只用判断末尾。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int a[4],m,n;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		a[1]=m%10;
		a[2]=(a[1]*a[1])%10;
		a[3]=(a[1]*a[2])%10;
		a[0]=(a[1]*a[3])%10;
		n=n%4;
		printf("%d\n",a[n]);
	}
	return 0;
}


你可能感兴趣的:(hdoj-1097-A hard puzzle)