Hduoj1019【水题】

/*Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38399    Accepted Submission(s): 14479


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the 
numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the 
number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number 
of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
 
Sample Output
105
10296

Source
East Central North America 2003, Practice 
*/
#include<stdio.h>
#include<string.h>
int gcd(int x, int y)
{
	if(y == 0)
	return x;
	else
	return gcd(y, x%y);
} 
int main()
{
	int i, j, k, t, n;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d", &n);
		int a = 1, b;
		for(i = 0; i < n;++i)
		{
			scanf("%d", &b);
			a = a / gcd(a, b) * b;
		}
		printf("%d\n", a);
	}
	return 0;
} 


题意:找n个数的最小公倍数。

思路:先利用gcd找出最大公约数,再求最小公倍数。

你可能感兴趣的:(Hduoj1019【水题】)