uva History Grading lcs

F - History Grading
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu
Submit Status Practice UVA 111
Appoint description:

Description

Background

Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events as where denotes the ranking of event i in the correct chronological order and a sequence of student responses where denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events with . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9


输入一串数字表示历史事件发生的先后顺序

比如 1324 表示 事件一最先发生 然后是事件3 然后是事件2 最后是事件4

输入一个标准答案

然后输入若干学生的答案 问学生答案中按照原来正确历史事件发生的个数是多少

就是求和标准答案的lcs

ACcode:

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define maxn 1000
using namespace std;
int a[maxn],b[maxn];
int dp[2][maxn];
int n,tmp;
int main(){
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;++i){
            scanf("%d",&tmp);
            a[tmp]=i;
        }
        while(scanf("%d",&tmp)!=EOF){
            b[tmp]=1;
            for(int i=2;i<=n;++i){
                scanf("%d",&tmp);
                b[tmp]=i;
            }
            memset(dp,0,sizeof(dp));
            for(int i=1;i<=n;++i)
                for(int j=1;j<=n;++j)
                    if(a[i]==b[j])
                        dp[i&1][j]=dp[(i+1)&1][j-1]+1;
                    else
                        dp[i&1][j]=max(dp[i&1][j-1],dp[(i+1)&1][j]);
            printf("%d\n",dp[n&1][n]);
        }
    }
    return 0;
}


你可能感兴趣的:(C++,dp)