Hduoj1016【深搜】【水题】

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33730    Accepted Submission(s): 14932


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Hduoj1016【深搜】【水题】_第1张图片
 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
   
   
   
   
6 8
 

Sample Output
   
   
   
   
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
Asia 1996, Shanghai (Mainland China) 
#include<stdio.h>
#include<string.h>
int prim[42], r[22], num, vis[22], n;
void getprim()
{
	prim[1] = 1;
	for(int i = 2; i < 8; ++i)
	{
		for(int j = 2*i; j < 42; j += i)
		prim[j] = 1;
	}
} 
void dfs(int x)
{
	if(num == n)
	{
		if(!prim[r[num] + r[1]])
		{
			for(int i = 1; i < n; ++i)
			printf("%d ", r[i]);
			printf("%d\n", r[n]); 
			
		}
		return ;
	}
	for(int i = 2; i <= n; ++i)
	{
		if(!vis[i] && ! prim[r[num] + i])
		{
			r[++num] = i;
			vis[i] = 1;
			dfs(i);
			num--;
			vis[i] = 0;
		}
	}
}
int main()
{
	int i, j, k, cas =  1;
	getprim();
	while(scanf("%d", &n) != EOF)
	{
		memset(vis, 0, sizeof(vis));
		memset(r, 0, sizeof(r));
		r[1] = 1;
		num = 1;
		printf("Case %d:\n", cas++);
		dfs(1);
		printf("\n");
	}
	return 0;
}

题意:给出一个数n,要求1~n,这n个数字构成一个素数环,即环中的任意前后2项之和为素数,输出这个环以1为开头的顺时针序列。
思路:先打素数表,再深搜。

你可能感兴趣的:(Hduoj1016【深搜】【水题】)