What Is Your Grade?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9946 Accepted Submission(s): 3043
Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
Sample Output
Author
lcy
本身不难啊!!!就是不知道第一次的代码怎么就WAWAWAWAWA,下面也贴上吧,也许某天自己就检查出来了。
代码如下:
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
struct node
{
int list; //原来的排序
int n; //解决的题数
int time; //花的时间(转化为秒)
int grade; //最终成绩
}pre[111];
bool cmp1(node a,node b)
{
if (a.n==b.n)
return a.time<b.time;
return a.n>b.n;
}
bool cmp2(node a,node b)
{
return a.list<b.list;
}
int main()
{
int u;
int num[6];
int th,tm,ts; //时间
while (~scanf ("%d",&u) && (u>0))
{
memset (num,0,sizeof (num));
for (int i=0;i<u;i++)
{
scanf ("%d %d:%d:%d",&pre[i].n,&th,&tm,&ts);
pre[i].grade=50+pre[i].n*10;
pre[i].list=i;
pre[i].time=3600*th+60*tm+ts;
num[pre[i].n]++;
}
sort (pre,pre+u,cmp1);
num[1]/=2;
num[2]/=2;
num[3]/=2;
num[4]/=2;
for (int i=0,j=4;i<u;i++)
{
if (pre[i].n==0 || pre[i].n==5)
continue;
j=pre[i].n;
if (num[j]==0)
continue;
else
{
pre[i].grade+=5;
num[j]--;
}
}
// for (int j=0,i=5;j<u;j++)
// {
// if (!pre[j].n)
// break;
// if (pre[j].n!=i) //寻出下一组的第一个
// {
// for (int x=1;x<=num[pre[j].n]/2;x++) //前一半+5分
// {
// int l=j;
// pre[l++].grade+=5;
// }
// i=pre[j].n;
// j+=num[pre[j].n];
// }
// }
sort (pre,pre+u,cmp2);
for (int i=0;i<u;i++)
{
printf ("%d\n",pre[i].grade);
}
printf ("\n");
}
return 0;
}
PS:注释掉的那一段为
WA的代码。