nefu 636

description

There are n classes in Mr Li's grade.And each class have m students.The last examination's ranked results have been finished.Now Mr Li wants to know the score of the student who got the kth place.
							

input

 Each test case have three integers n,m,k(1 <= n <= 10, 1 <= m <= 100,1 <= k <= n*m) in the first line.Then,there are n lines,one line indicating the scores of one class.Each line contains m positive integers.
   Process to the end of file.

output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case.Then,output one integer the score of student who are placed kth,in one line.Print a blank line after each test case, even after the last one.

sample_input

2 4 4
90 87 98 59
78 67 88 99

sample_output

Scenario #1
88
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int cmp(int a,int b)
{
    return a>b;
}
int a[100005];
int main()
{
    int t=1,n,m,k;
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        for(int i=0;i<n*m;i++)
            scanf("%d",&a[i]);
        sort(a,a+(n*m),cmp);
        printf("Scenario #%d\n%d\n",t++,a[k-1]);
    }
    return 0;
}
<br /><span id="_xhe_temp" width="0" height="0"><br /></span>

你可能感兴趣的:(nefu 636)