An easy problem
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10149 Accepted Submission(s): 2689
Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
We can define sum(n) as follow:
if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
Is it very easy ? Please begin to program to AC it..-_-
Input
The input file contains multilple cases.
Every cases contain only ont line, every line contains a integer n (n<=100000).
when n is a negative indicate the end of file.
Output
output the result sum(n).
Sample Input
1
2
3
-1
Sample Output
1
3
30
Author
Wendell
Source
HDU 2007-11 Programming Contest_WarmUp
题目大意:给了递推公式,如果当前i%3==0,则sum(i) = sum(i-1) + i*i*i;否则
sum(i) = sum(i-1) + i。
思路:因为数据略大一些,所以用__int64整型来存储结果。
#include<iostream>
#include<algorithm>
using namespace std;
__int64 ans[100010];
int main()
{
for(__int64 i = 1; i <= 100000; ++i)
{
if(i % 3 == 0)
ans[i] = ans[i-1] + i*i*i;
else
ans[i] = ans[i-1] + i;
}
__int64 N;
while(cin >> N && N >= 0)
{
cout << ans[N] << endl;
}
return 0;
}