POJ 2665 Trees(水~)

Desciption
给出一段路,每隔一米有一棵树,现在需要修几段路,修路区域的树需要砍伐或者移走,求剩下的树木数
Input
多组用例,每组用例第一行为两个整数l和n表示路的总长和修路的段数,之后n行每行两个整数表示修路的区域,以l=n=0结束输入
Output
对于每组用例,输出剩余树木数
Sample Input
300 1
100 200
500 2
100 200
201 300
0 0
Sample Output
200
300
Solution
水题
Code

#include<stdio.h>
int main()
{
    int l,n;
    while(scanf("%d%d",&l,&n),l)
    {
        int res=l+1;//树的数量 
        int l,r;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&l,&r);
            res-=(r-l+1);//减去修路区域的树 
        }
        printf("%d\n",res);
    }
    return 0;
}

你可能感兴趣的:(POJ 2665 Trees(水~))