Big Event in HDU
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18647 Accepted Submission(s): 6522
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
Sample Output
Author
lcy
本题给出若干类型的工厂,每类工厂的价值、数量,要求尽可能总价值相同的均匀地将这批工厂分成两部分,输出两部分的各自价值。
本题可以等价于多重背包,每类工厂的价值分别对应物品的重量与价值,然后求载重量为sum/2的背包最大可以装多少价值。
#include<iostream>
#include<cstdio>
using namespace std;
//*****************************************************************
int dp[100*50*50+1000];//是具体情况而定
struct node
{
int num,weight,value;//分别代表每种物品的数量、重量、价值
}Good[55];//定义每个物品的结构体
int Max_weight;//背包的载重量
int max(int a,int b)
{
return a<b?b:a;
}
void ZeroOnePack(int weight,int value,int lim)
//对应01背包的求法
{
for(int i=lim;i>=weight;i--)
dp[i]=max(dp[i],dp[i-weight]+value);
}
void CompletePack(int weight,int value,int lim)
//对应完全背包的求法
{
for(int i=weight;i<=lim;i++)
dp[i]=max(dp[i],dp[i-weight]+value);
}
void MultiplePack(int weight,int value,int amount,int lim)
//选定物品后的多重背包的求法
{
if(weight*amount>=lim)CompletePack(weight,value,lim);
else
{
for(int k=1;k<amount;)
{
ZeroOnePack(k*weight,k*value,lim);
amount-=k;
k<<=1;
}
ZeroOnePack(amount*weight,amount*value,lim);
}
}
void Solve(int n)
//解决物品种类数为n的多重背包问题求法
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
MultiplePack(Good[i].weight,Good[i].value,Good[i].num,Max_weight);
}
//*****************************************************************
int main()
{
int n,i;
int sum;
while(~scanf("%d",&n))
{
if(n<0)
break;
sum=0;
for(i=1;i<=n;i++)
{
scanf("%d%d",&Good[i].value,&Good[i].num);
Good[i].weight=Good[i].value;
sum+=Good[i].weight*Good[i].num;
}
Max_weight=sum/2;
Solve(n);
if(dp[Max_weight]>=sum-dp[Max_weight])
printf("%d %d\n",dp[Max_weight],sum-dp[Max_weight]);
else
printf("%d %d\n",sum-dp[Max_weight],dp[Max_weight]);
}
return 0;
}