hdoj 1711 Number Sequence 【kmp】

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13431    Accepted Submission(s): 6058


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
   
   
   
   
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

Sample Output
   
   
   
   
6 -1
mp:1279ms
 
#include <cstdio>
#include <cstring>
#define MAX 1000000+10
using namespace std;
int f[MAX];
int P[MAX], T[MAX]; 
int n, m;
void getfail()
{
    int i, j;
    f[0] = f[1] = 0;
    for(i = 1; i < m; i++)
    {
        j = f[i];
        while(j && P[i] != P[j])
        j = f[j];
        f[i+1] = P[i]==P[j]?j+1:0;
    }
}
void find()
{
    int i;
    int j = 0;
    for(i = 0; i < n; i++)
    {
        while(j && T[i] != P[j])//直到匹配 
        j = f[j];
        if(T[i] == P[j])//累加 
        j++;
        if(j >= m)
        {
            printf("%d\n", i-m+1+1);//下标从0开始的 
            return ;
        }
    }
    printf("-1\n"); 
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        for(int i = 0; i < n; i++)
        scanf("%d", &T[i]);
        for(int i = 0; i < m; ++i)
        scanf("%d", &P[i]);
        getfail();
        find();
    } 
    return 0;
}

kmp:1060ms
 
#include <cstdio>
#include <cstring>
#define MAX 1000000+10
using namespace std;
int f[MAX];
int P[MAX], T[MAX];
int n, m;
void getfail()
{
    int i = 0;
    int j = -1;
    f[0] = -1;
    while(i < m)
    {
        if(j == -1 || P[i] == P[j])
        f[++i] = ++j;
        else
        j = f[j];
    }
}
void find()
{
    int i = 0, j = 0;
    while(i < n)
    {
        while(j != -1 && T[i] != P[j])
        j = f[j];
        ++i,++j;
        if(j >= m)
        {
            printf("%d\n", i-m+1);
            return ;
        }
    }
    printf("-1\n");
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        for(int i = 0; i < n; i++)
        scanf("%d", &T[i]);
        for(int i = 0; i < m; i++)
        scanf("%d", &P[i]);
        getfail();
        find();
    }
    return 0;
}

你可能感兴趣的:(hdoj 1711 Number Sequence 【kmp】)