poj3071(概率DP)

Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2273   Accepted: 1132

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. Aftern rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that teami will beat teamj in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containingn (1 ≤n ≤ 7). The next 2n lines each contain 2n values; here, thejth value on theith line represents pij. The matrixP will satisfy the constraints thatpij = 1.0 −pji for allij, and pii = 0.0 for alli. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either thedouble data type instead offloat.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source

Stanford Local 2006
 
本题要求相互比赛n轮之后赢的概率最大的队伍。这题是个较裸的概率DP问题。
我们需要求得n轮过后概率最大的那个,必须一轮一轮的往上推。而队伍之间的比赛关系不能任意,在一颗竞赛树上。第i轮能比赛的两个队伍必须出第i-1位不同之外,其余位必须完全相同。状态转移方程为
                     dp[i][j]=∑(dp[i-1][j]*dp[i-1][k]*p[j][k]),其中(j<<(i-1)^1)==k<<(i-1),注意位运算的正确使用。
 
#include<iostream>
#include<cstdio>
using namespace std;

int n;
double dp[10][400];
double p[400][400];

int main()
{
	int i,j,m,s;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==-1)
			break;
		m=1<<n;
        memset(dp,0,sizeof(dp));
        for(i=0;i<m;i++)
        {
			for(j=0;j<m;j++)
            scanf("%lf",&p[i][j]);
		}
		//初始化1
		 for(i=0;i<m;i++)
			  dp[0][i]=1;
		  for(i=1;i<=n;i++)
		  {
			  for(j=0;j<m;j++)
			  {
				  for(s=0;s<m;s++)
				  {
					//  if((s>>(i-1))^(j>>(i-1)))
					  if(((s>>(i-1))^1)==(j>>(i-1)))//从右到左除第i-1为不同之外,其余都相同
						  dp[i][j]+=dp[i-1][j]*dp[i-1][s]*p[j][s];
				  }
			  }
		  }
		  //选出第n轮之后概率最大的
		  int ans=0;
		  for(i=1;i<m;i++)
		  {
			  if(dp[n][ans]<dp[n][i])
				  ans=i;
		  }
		  printf("%d\n",ans+1);
	}
	return 0;
}



你可能感兴趣的:(动态规划)