Intervals
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2880 Accepted Submission(s): 1048
Problem Description
You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.
Write a program that:
> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input,
> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n,
> writes the answer to the standard output
Input
The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1.
Process to the end of file.
Output
The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n.
Sample Input
5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1
Sample Output
Author
1384
#include <stdio.h>
#include <queue>
#include <string.h>
#define maxn 50010
#define inf 0x3f3f3f3f
using std::queue;
int head[maxn], id, dist[maxn];
int left, right;
struct Node{
int to, w, next;
} E[maxn * 3];
bool vis[maxn];
void addEdge(int u, int v, int c)
{
E[id].to = v; E[id].w = c;
E[id].next = head[u]; head[u] = id++;
}
int SPFA()
{
memset(dist, 0x3f, sizeof(dist));
memset(vis, 0, sizeof(vis));
int i, u, v, tmp;
u = right; vis[u] = 1; dist[u] = 0;
queue<int> Q; Q.push(u);
while(!Q.empty()){
u = Q.front(); Q.pop(); vis[u] = 0;
for(i = head[u]; i != -1; i = E[i].next){
tmp = dist[u] + E[i].w;
v = E[i].to;
if(tmp < dist[v]){
dist[v] = tmp;
if(!vis[v]){
vis[v] = true;
Q.push(v);
}
}
}
}
return -dist[left];
}
int main()
{
int n, a, b, c, i;
while(scanf("%d", &n) == 1){
memset(head, -1, sizeof(head));
left = inf; right = 0;
for(i = id = 0; i < n; ++i){
scanf("%d%d%d", &a, &b, &c);
addEdge(b + 1, a, -c);
if(left > a) left = a;
if(right < b) right = b;
}
++right;
for(i = left; i <= right; ++i){
addEdge(i, i + 1, 1);
addEdge(i + 1, i, 0);
}
printf("%d\n", SPFA());
}
return 0;
}