http://poj.org/problem?id=2406

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 19478 Accepted: 8129

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4

3

这道题通俗一点讲就是求所给字符串的周期,,这里用了KMP高效算法来解决。。

这样,我们用(length)-next[length]就是字符串向右移动的位数,.然后用总的长度除以这个向右移动的位数,

如果能除尽的话,结果就是重复的次数,否则重复的次数为1.即:
if(length%((length)-next[length])==0)
count=length/(length-next[length]);

else cout=1;

AC代码:

#include<iostream>
#include<string.h>
#include<cstdio>
#define M 1000001
using namespace std;
int next[M];
char s[M];
int main()
{   int i,j,k;
    while(1)
  {  scanf("%s",s);
    if(strcmp(s,".")==0)
     break;
     int len=strlen(s);
     i=0;j=-1;
     next[0]=-1;
     while(i<len)
     { if(j==-1||s[i]==s[j])
         { i++;j++;
           next[i]=j;
           
           }
           else  j=next[j];
     }
     j=i-next[i];
     if(i%j==0)  k=i/j;
     else k=1;
      printf("%d\n",k);
     
            }return 0;
    }
 


你可能感兴趣的:(String,Integer,input,each,output,concatenation)