HDU 1789 Doing Homework again!

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
STD Contests 
VIP Contests 
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests
Author 只会C语言
Mail Mail 0(0)
Control Panel Control Panel 
Sign Out Sign Out
你准备参加HDU-ACM暑期集训队的选拔吗?点击查看详情!
金牌预测——2012浙江省第九届大学生程序设计竞赛(4月14日)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2355    Accepted Submission(s): 1381


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
       
       
       
       
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
       
       
       
       
0 3 5
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define max 1005
struct node
{
    int x,y;
};
int cmp(const void*a,const void *b)
{
    return -((*(struct node*)a).y-(*(struct node*)b).y);
}
int main()
{
    int i,n,m,j,k;
    int flag;
    int re[max];
    int sum;
    struct node data[max];
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        memset(re,0,sizeof(int)*max);
        sum=0;
        scanf("%d",&m);
        for(j=0;j<m;j++)
        {
            scanf("%d",&data[j].x);
        }
        for(j=0;j<m;j++)
        {
            scanf("%d",&data[j].y);
        }
        qsort(data,m,sizeof(struct node),cmp);
        for(j=0;j<m;j++)
        {
            flag=0;
            for(k=data[j].x-1;k>=0;k--)
            {
                if(re[k]==0)
                {
                    re[k]=data[j].y;
                    flag=1;
                    break;
                }
            }
            if(!flag)sum+=data[j].y;
        }
        printf("%d\n",sum);
    }
    return 0;
}



你可能感兴趣的:(HDU 1789 Doing Homework again!)