HDU 1060 Leftmost Digit


Problem Description
   
   
   
   
Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
 

Input
   
   
   
   
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
   
   
   
   
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
 

Sample Input
   
   
   
   
100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75
 

Sample Output
   
   
   
   
$1581.42
求N的N次方的值的最高位,假定N^N等于A*10^B两边各取对对就出来了,double转整形的时候要用long long不然要出错。
LANGUAGE:C++
CODE:
#include<iostream>
#include<cmath>
using namespace std;

int main()
{
    int cas;
    while(cin>>cas)
    {
        while(cas--)
        {
            unsigned long num;
            cin>>num;
            double x=num*log10(num*1.0);
            cout<<(int)pow(10.0,x-(__int64)x)<<endl;
        }
    }
    return 0;
}




你可能感兴趣的:(input,each,output)