zoj 2478 Encoding

1、http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2478

2、题目:

Encoding

           

           

                Time Limit: 2 Seconds                                    Memory Limit: 65536 KB                           

           

           

Given a string containing only 'A' - 'Z', we could encode it using the following   method:

1. Each sub-string containing k same characters should be encoded to "kX"   where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.


  Input

The first line contains an integer N (1 <= N <= 100) which indicates   the number of test cases. The next N lines contain N strings. Each string consists   of only 'A' - 'Z' and the length is less than 100.


  Output

For each test case, output the encoded string in a line.


  Sample Input

2
  ABC
  ABBCCC


  Sample Output

ABC
  A2B3C

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char str[110];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str);
        int len=strlen(str),j;
        for(int i=0;i<len;)
        {
            if(str[i]!=str[i+1])
            {
                printf("%c",str[i]);
                i++;
            }
            else
            {
                int count=1;
                for(j=i+1;j<len;j++)
                {
                    if(str[i]==str[j])
                    count++;
                    else
                    break;
                }
                 printf("%d%c",count,str[i]);
                i=j;

            }
        }
        printf("\n");
    }
    return 0;
}


你可能感兴趣的:(zoj 2478 Encoding)