poj 3259 Wormholes 【spfa判断是否存在负环】

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 34513   Accepted: 12602

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
 

题意:John的农场里有n块地和m条路双向路以及w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退T秒。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。

说下输入:n块地,m条边,w个虫洞。下面依次是m条边的信息(双向),输入完后是w个虫洞的信息(单向)。

思路:spfa。由于存在负权边,Dijkstra便不能用了。简化题目->就是看图中有没有负权环,有的话John可以无限次走这个环,使得时间一定能得到一个负值。所以存在负环话就是可以,没有的话就是不可以了。

 

spfa邻接表:157ms

 

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define MAXN 500+100
#define MAXM 5000+700
#define INF 0x3f3f3f
using namespace std;
struct Edge
{
    int to, val, next;
}edge[MAXM];
int dist[MAXN], vis[MAXM], used[MAXM], head[MAXM], top;
queue<int> Q;
int n, m, w;
void addedge(int a, int b, int d)
{
    edge[top].to = b;
    edge[top].val = d;
    edge[top].next = head[a];
    head[a] = top++;
}
void init()
{
    top = 0;
    for(int i = 1; i <= n; i++)
    {
        used[i] = 0;
        vis[i] = 0;
        head[i] = -1;
    }
}
void spfa()
{
    int i;
    for(i = 1; i <= n; i++)
    dist[i] = INF;
    while(!Q.empty())
    {
        Q.pop();
    }
    Q.push(1);
    dist[1] = 0;
    used[1]++;
    vis[1] = 1;
    while(!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        vis[u] = 0;//清除标记
        for(i = head[u]; i != -1; i = edge[i].next)
        {
            int v = edge[i].to;
            if(dist[v] > dist[u] + edge[i].val)
            {
                dist[v] = dist[u] + edge[i].val;
                if(!vis[v])
                {
                    vis[v] = 1;
                    used[v]++;
                    if(used[v] > n)//存在负环 
                    {
                        printf("YES\n");
                        return ;
                    }
                    Q.push(v);
                }
            }
        } 
    }
    printf("NO\n");
}
int main()
{
    int t;
    int a, b, d;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d%d", &n, &m, &w);
        init();
        while(m--)
        {
            scanf("%d%d%d", &a, &b, &d);
            addedge(a, b, d);
            addedge(b, a, d);
        }
        while(w--)
        {
            scanf("%d%d%d", &a, &b, &d);
            addedge(a, b, -d);//建立负权边 
        }
        spfa();
    }
    return 0;
}


 

 

你可能感兴趣的:(poj 3259 Wormholes 【spfa判断是否存在负环】)