HDU4961:Boring Sum

Problem Description
Number theory is interesting, while this problem is boring.

Here is the problem. Given an integer sequence a 1, a 2, …, a n, let S(i) = {j|1<=j<i, and a j is a multiple of a i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a f(i). Similarly, let T(i) = {j|i<j<=n, and a j is a multiple of a i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c i as a g(i). The boring sum of this sequence is defined as b 1 * c 1 + b 2 * c 2 + … + b n * c n.

Given an integer sequence, your task is to calculate its boring sum.
 

Input
The input contains multiple test cases.

Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a 1, a 2, …, a n (1<= a i<=100000).

The input is terminated by n = 0.
 

Output
Output the answer in a line.
 

Sample Input
   
   
   
   
5 1 4 2 3 9 0
 

Sample Output
   
   
   
   
136
Hint
In the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.
 

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,b) memset(a,b,sizeof(a))
#define w(x) while(x)
#define l 100005
#define ll __int64
#define s(a) scanf("%I64d",&a)
ll vis[l],a[l],b[l],c[l],n,i,j,ans;

int main()
{
    w((s(n),n))
    {
        up(i,1,n)
        s(a[i]);
        mem(vis,0);
        up(i,1,n)
        {
            if(vis[a[i]])
                b[i]=a[vis[a[i]]];
            else
                b[i]=a[i];
            up(j,1,sqrt(a[i]*1.0)+1)
            {
                if(a[i]%j==0)
                    vis[j]=vis[a[i]/j]=i;
            }
        }
        mem(vis,0);
        down(i,n,1)
        {
            if(vis[a[i]])
                c[i]=a[vis[a[i]]];
            else
                c[i]=a[i];
            up(j,1,sqrt(a[i]*1.0)+1)
            {
                if(a[i]%j==0)
                    vis[j]=vis[a[i]/j]=i;
            }
        }
        ans=0;
        up(i,1,n)
        ans+=b[i]*c[i];
        printf("%I64d\n",ans);
    }

    return 0;
}



你可能感兴趣的:(HDU)